So Tired !_! 逆水行舟, 不进则退!

7Jun/12

在Eclipse Indigo安装UML2 Tools

UML2 Tools 是Eclipse的一个用于支持画UML2图的重要插件,可是如果你用的是Hellios或者Indigo版本的Eclipse,会发现无法安装下载的 UML2 Tools SDK,提示错误一般是找不到包括org.eclipse.emf.ocl feature在内的dependency。

原因是:从Hellios开始,这个feature就不再被Eclipse支持,虽然仍然有不少plugin依赖这个feature,比如这个UML2 Tools SDK。

在UML2 Tools取消这个依赖之前,如果想使用它,唯一的办法就是临时装上org.eclipse.emf.ocl这个feature,步骤如下。

1、从https://bugs.eclipse.org/bugs/attachment.cgi?id=173482 下载rog.eclipse.emf.ocl-update.zip。

2、在Eclipse的Help -> Install New Software安装这个功能。

3、从http://www.eclipse.org/modeling/mdt/downloads/?project=uml2tools 下载最新的UML2 tools SDK zip文件。

4、同样在Eclipse的Help -> Install New Software安装这个功能。

这次就不会遇到cannot resolve dependency的问题了。

 

安装结束,重启Eclipse,在创建新的项目中就出现了UML 2.1 Diagrams

 

这里有一个简单的UML Tools Tutorial

anyShare分享到:
Comments (0) Trackbacks (0)

No comments yet.


Leave a comment

No trackbacks yet.

site