How to create a bootable USB stick on OS X

We would encourage M.

We would encourage Mac users to download Ubuntu Desktop Edition by burning a CD. But if you prefer to use a USB stick, please follow the instructions below.

Note: this procedure requires that you create an .img file from the .iso file you download. It will also change the filesystem that is on the USB stick to make it bootable, so backup all data before continuing.

Tip: Drag and drop a file from Finder to Terminal to ‘paste’ the full path without risking typing errors.

  1. 1
  2. 2

    Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight).

  3. 3

    Convert the .iso file to .img using the convert option of hdiutil e.g.,

    hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/ubuntu.iso

    Note: OS X tends to put the .dmg ending on the output file automatically.

  4. 4

    Run

    diskutil list

    to get the current list of devices.

  5. 5

    Insert your flash media.

  6. 6

    Run

    diskutil list

    again and determine the device node assigned to your flash media (e.g. /dev/disk2).

  7. 7

    Run

    diskutil unmountDisk /dev/diskN

    (replace N with the disk number from the last command; in the previous example, N would be 2).

  8. 8

    Execute

    sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m

    (replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.img or ./ubuntu.dmg).

    • Using /dev/rdisk instead of /dev/disk may be faster
    • If you see the error dd: Invalid number ‘1m’, you are using GNU dd. Use the same command but replace bs=1m with bs=1M
    • If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the ‘Disk Utility.app’ and unmount (don’t eject) the drive
  9. 9

    Run

    diskutil eject /dev/diskN

    and remove your flash media when the command completes.

  10. 10

    Restart your Mac and press alt/option key while the Mac is restarting to choose the USB stick.