Directly from the Ubuntu download page (my formatting):
- Download the desired file
- Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight)
- Convert the .iso file to .img using the convert option of hdiutil (e.g.,
hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/ubuntu.iso
) - Note: OS X tends to put the .dmg ending on the output file automatically. Remove the .dmg extension as necessary,
mv ~/path/to/target.img{.dmg,}
- Run
diskutil list
to get the current list of devices - Insert your flash media
- Run
diskutil list
again and determine the device node assigned to your flash media (e.g./dev/disk2
) - Run
diskutil unmountDisk /dev/diskN
(replaceN
with the disk number from the last command; in the previous example,N
would be 2) - Execute
sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m
(replace/path/to/downloaded.img
with the path where the image file is located; for example,./ubuntu.img
or./ubuntu.dmg
). - Using
/dev/rdisk
instead of/dev/disk
may be faster.- If you see the error
dd: Invalid number '1m'
, you are using GNUdd
. Use the same command but replacebs=1m
withbs=1M
. - If you see the error
dd: /dev/diskN: Resource busy
, make sure the disk is not in use. Start the ‘Disk Utility.app’ and unmount (don’t eject) the drive.
- If you see the error
- Run
diskutil eject /dev/diskN
and remove your flash media when the command completes - Restart your Mac and hold down Alt while the Mac is restarting to choose the USB stick
Note: On newer Macs you might have to install an EFI boot manager to boot from USB.